GetAssociatedZoneEquipment Method (Document, ISet(ElementId))


Gets the associated zone equipment of all specified analytical spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020.1

Syntax

C#
public static ISet<ElementId> GetAssociatedZoneEquipment(
	Document document,
	ISet<ElementId> spaces
)
Visual Basic
Public Shared Function GetAssociatedZoneEquipment ( _
	document As Document, _
	spaces As ISet(Of ElementId) _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAssociatedZoneEquipment(
	Document^ document, 
	ISet<ElementId^>^ spaces
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document where the analytical spaces and zone equipment exist.
spaces
Type: System.Collections.Generic ISet ElementId
The specified analytical spaces.

Return Value

All associated zone equipment, either explicitly assigned or implicitly assigned via system-zone.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also