GetAssociatedZoneEquipment Method (Document, ISet(ElementId))


Zone Equipment Get Associated Zone Equipment(Document, ISet Element Id ) Method

Gets the associated zone equipment of all specified analytical spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetAssociatedZoneEquipment(
	Document document,
	ISet<ElementId> spaces
)

Parameters

document Document
The document where the analytical spaces and zone equipment exist.
spaces ISet ElementId
The specified analytical spaces.

Return Value

ISet ElementId
All associated zone equipment, either explicitly assigned or implicitly assigned via system-zone.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also