Creates a new analytical connection between two open connectors.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document where the new element is created.
- typeId
- Type: Autodesk.Revit.DB ElementId
The type of new analytical connection.
- startConnector
- Type: Autodesk.Revit.DB Connector
The open connector on the equipment side, whose level is inherited by the analytical connection.
- endConnector
- Type: Autodesk.Revit.DB Connector
The open connector on the network.
Return Value
The newly created analytical connection element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Invalid connection type. -or- The connector does not support analytical connection. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |