Create Method


MEPAnalytical Connection Create Method

Creates a new analytical connection between two open connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MEPAnalyticalConnection Create(
	Document doc,
	ElementId typeId,
	Connector startConnector,
	Connector endConnector
)

Parameters

doc Document
The document where the new element is created.
typeId ElementId
The type of new analytical connection.
startConnector Connector
The open connector on the equipment side, whose level is inherited by the analytical connection.
endConnector Connector
The open connector on the network.

Return Value

MEPAnalyticalConnection
The newly created analytical connection element.
Exceptions
Exception Condition
ArgumentException Invalid connection type. -or- The connector does not support analytical connection.
ArgumentNullException A non-optional argument was null
See Also