Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- key
- Type: Autodesk.Revit.DB Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
- item
- Type: Autodesk.Revit.DB Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
- groupTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.