ReInsert Method (Definition, Binding, ForgeTypeId)


Binding Map Re Insert(Definition, Binding, Forge Type Id) Method

Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual bool ReInsert(
	Definition key,
	Binding item,
	ForgeTypeId groupTypeId
)

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
groupTypeId ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.
See Also