Sets collection of properties stored in this property list.
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- value
- Type: System.Collections.Generic IList AssetProperty
An array of properties.
Remarks
All the properties in the list are of the same AssetPropertyType. The AssetPropertyType can only be Integer, Double4, Float or Double, Enumeration.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input value is invalid for this AssetPropertyList property. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The asset property is not editable. |