Asset |
Sets collection of properties stored in this property list.
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- value IList AssetProperty
- An array of properties.

Exception | Condition |
---|---|
ArgumentException | The input value is invalid for this AssetPropertyList property. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The asset property is not editable. |

All the properties in the list are of the same AssetPropertyType. The AssetPropertyType can only be Integer, Double4, Float or Double, Enumeration.