A type to help identify the individual face on a host element to which a Rebar handle
is constrained.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2014
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
FaceWithTagId | Face identified by integer tag. |
Top | Face forms the top surface of the host geometry. |
Bottom | Face forms the bottom surface of the host geometry. |
End0 | Face forms the starting end surface of the host geometry. |
End1 | Face forms the end surface of the host geometry. |
Side0 | Face forms the exterior surface of the host geometry. |
Side1 | Face forms the interior surface of the host geometry. |
Remarks
For some types of host, it is possible to describe the face in terms of recognizable
topology (i.e. Top, Bottom, etc.). However, for most elements, the face can only be
identified by integer tag. In all cases, a Pick to the host face can be obtained
by calling RebarConstraint.GetTargetHostFaceReference().