RebarConstraintTargetHostFaceType Enumeration


Rebar Constraint Target Host Face Type Enumeration

A type to help identify the individual face on a host element to which a Rebar handle is constrained.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarConstraintTargetHostFaceType
Members
Member name Value Description
Bottom 2 Face forms the bottom surface of the host geometry.
End0 3 Face forms the starting end surface of the host geometry.
End1 4 Face forms the end surface of the host geometry.
FaceWithTagId 0 Face identified by integer tag.
Side0 5 Face forms the exterior surface of the host geometry.
Side1 6 Face forms the interior surface of the host geometry.
Top 1 Face forms the top surface of the host geometry.
Remarks
For some types of host, it is possible to describe the face in terms of recognizable topology (i.e. Top, Bottom, etc.). However, for most elements, the face can only be identified by integer tag. In all cases, a Pick to the host face can be obtained by calling RebarConstraint.GetTargetHostFaceReference().
See Also