ElementIntersectsSolidFilter Constructor (Solid)


Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012

Syntax

C#
public ElementIntersectsSolidFilter(
	Solid solid
)
Visual Basic
Public Sub New ( _
	solid As Solid _
)
Visual C++
public:
ElementIntersectsSolidFilter(
	Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB Solid
The solid geometry to check for intersection.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also