Checks if resolution of the failure using given resolution type is permitted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- failure
- Type: Autodesk.Revit.DB FailureMessageAccessor
Accessor to the failure to be resolved.
- resolutionType
- Type: Autodesk.Revit.DB FailureResolutionType
Type of the failure resolution to be used.
Return Value
True if resolution of the failure using given resolution type is permitted.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | failure has not been properly initialized. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |