Checks if resolution of the failure using given resolution type is permitted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- failure
- Type: Autodesk.Revit.DBFailureMessageAccessor
Accessor to the failure to be resolved.
- resolutionType
- Type: Autodesk.Revit.DBFailureResolutionType
Type of the failure resolution to be used.
Return Value
True if resolution of the failure using given resolution type is permitted.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | failure has not been properly initialized. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |