IsAlmostEqualTo Method (XYZ)


Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public bool IsAlmostEqualTo(
	XYZ source
)
Visual Basic
Public Function IsAlmostEqualTo ( _
	source As XYZ _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
	XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Remarks

This routine uses Revit's default tolerance to compare two vectors to see if they are almost equivalent. Because the tolerance is small enough this can also be used to compare two points.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when source is a null reference ( Nothing in Visual Basic) .

See Also