XYZ Is |
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- source XYZ
- The vector to compare with this vector.
Return Value
BooleanTrue if the vectors are the same; otherwise, false.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when source is . |

This routine uses Revit's default tolerance to compare two vectors to see if they are almost equivalent. Because the tolerance is small enough this can also be used to compare two points.