ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory), Boolean)


Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public ElementMulticategoryFilter(
	ICollection<BuiltInCategory> categories,
	bool inverted
)
Visual Basic
Public Sub New ( _
	categories As ICollection(Of BuiltInCategory), _
	inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
	ICollection<BuiltInCategory>^ categories, 
	bool inverted
)

Parameters

categories
Type: System.Collections.Generic ICollection BuiltInCategory
The built-in categories to match.
inverted
Type: System Boolean
True if the filter should match all elements which are not of the given built-in categories.

See Also