Checks whether the reference is in a valid format.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resourceType
-
Type:
Autodesk.Revit.DB
ExternalResourceType
The type of resource which the ExternalResourceReference should correspond to.
Return Value
True if this is a valid ExternalResourceReference. False otherwise.Remarks
This function checks:
- The server id corresponds to a valid server which implements IExternalResourceServer.
- The server supports the given ExternalResourceType.
- The reference information is well-formed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |