External |
Checks whether the reference is in a valid format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- resourceType ExternalResourceType
- The type of resource which the ExternalResourceReference should correspond to.
Return Value
BooleanTrue if this is a valid ExternalResourceReference. False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function checks:
- The server id corresponds to a valid server which implements IExternalResourceServer.
- The server supports the given ExternalResourceType.
- The reference information is well-formed.