Returns the filterable parameters common to the given categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
The document containing the categories and parameters to query.
- categories
- Type: System.Collections.Generic ICollection ElementId
The categories for which to determine the common parameters.
Return Value
The set of filterable parameters common to the given categories.Remarks
A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.
This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |