Parameter |
Returns the filterable parameters common to the given categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ICollection<ElementId> GetFilterableParametersInCommon(
Document aDoc,
ICollection<ElementId> categories
)
Parameters
- aDoc Document
- The document containing the categories and parameters to query.
- categories ICollection ElementId
- The categories for which to determine the common parameters.
Return Value
ICollection ElementIdThe set of filterable parameters common to the given categories.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.
This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.