Illuminance Property


The illuminance intensity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public double Illuminance { get; set; }
Visual Basic
Public Property Illuminance As Double
	Get
	Set
Visual C++
public:
property double Illuminance {
	double get ();
	void set (double value);
}

Field Value

The illuminance value in lx as a numerical value between 0 and 1e+30.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The illuminance value is not valid because it is not between 0 and 1e+30.

See Also