Set the fabrication configuration with specific profile.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fabricationConfigurationInfo
- Type: Autodesk.Revit.DB FabricationConfigurationInfo
The desired fabrication configuration.
- profile
- Type: System String
The desired profile of the fabrication configuration. Use empty string for the global profile.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The profile "profile" is invalid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration. |