Fabrication |
Set the fabrication configuration with specific profile.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetConfiguration(
FabricationConfigurationInfo fabricationConfigurationInfo,
string profile
)
Parameters
- fabricationConfigurationInfo FabricationConfigurationInfo
- The desired fabrication configuration.
- profile String
- The desired profile of the fabrication configuration. Use empty string for the global profile.

Exception | Condition |
---|---|
ArgumentException | The profile "profile" is invalid. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration. |