Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document.
- straightId
- Type: Autodesk.Revit.DB ElementId
Id of the straight to be cut in.
- fittingId
- Type: Autodesk.Revit.DB ElementId
Id of the fitting to cut in.
- position
- Type: Autodesk.Revit.DB XYZ
The position to cut in the straight.
- fittingConn
- Type: Autodesk.Revit.DB Connector
The connector of the fitting to align with the primary connector of the straight part.
- axisRotation
- Type: System Double
Rotation around the direction of connection - angle between width vectors in radians.
Return Value
True if cuts in successfully.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- fittingConn is not a connector of the fitting. -or- fittingConn is not valid, it is not within a pair connector for cutting in. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to align fitting to the straight to cut in. -or- There is no enough room in the run for cut in. |