PlaceFittingAsCutIn Method


Fabrication Part Place Fitting As Cut In Method

Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool PlaceFittingAsCutIn(
	Document document,
	ElementId straightId,
	ElementId fittingId,
	XYZ position,
	Connector fittingConnector,
	double axisRotation
)

Parameters

document Document
The document.
straightId ElementId
Identifier of the straight to be cut in.
fittingId ElementId
Identifier of the fitting to cut in.
position XYZ
The position to cut in the straight.
fittingConnector Connector
The connector of the fitting to align with the primary connector of the straight part.
axisRotation Double
Rotation around the direction of connection - angle between width vectors in radians.

Return Value

Boolean
True if cuts in successful.
Exceptions
Exception Condition
ArgumentException For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The fitting connector is not a connector of the fitting. -or- The fitting connector is not valid, it is not within a pair connector for cutting in.
ArgumentNullException A non-optional argument was null
InvalidOperationException Failed to align fitting to the straight to cut in. -or- There is no enough room in the run for cut in.
See Also