Creates a new CircuitNamingScheme.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the CircuitNamingScheme.
- name
- Type: System String
The name of CircuitNamingScheme.
- data
- Type: System.Collections.Generic IList TableCellCombinedParameterData
The array of TableCellCombinedParameterData to be set as combined parameters.
Return Value
The newly created CircuitNamingScheme.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a CircuitNamingScheme name. -or- The data contains invalid parameter id. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |