Creates a new CircuitNamingScheme.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which to create the CircuitNamingScheme.
- name
- Type: SystemString
The name of CircuitNamingScheme.
- data
- Type: System.Collections.GenericIListTableCellCombinedParameterData
The array of TableCellCombinedParameterData to be set as combined parameters.
Return Value
The newly created CircuitNamingScheme.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a CircuitNamingScheme name. -or- The data contains invalid parameter id. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |