Set the custom data real value for the specified custom data.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- customId
- Type: System Int32
The identifier of the custom data field to set.
- value
- Type: System String
The text value of the custom data. If the data is not a text type the value will be parsed according to the fabrication confifuration rules.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The custom data does not exist on the part. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |