SetPartCustomDataText Method


Fabrication Part Set Part Custom Data Text Method

Set the custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPartCustomDataText(
	int customId,
	string value
)

Parameters

customId Int32
The identifier of the custom data field to set.
value String
The text value of the custom data. If the data is not a text type the value will be parsed according to the fabrication confifuration rules.
Exceptions
Exception Condition
ArgumentException The custom data does not exist on the part.
ArgumentNullException A non-optional argument was null
See Also