An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
AtEachPoint | One normal vector is assigned to each vertex of the polymesh. |
OnePerFace | There is only one common normal vector assigned to the face/polymesh. |
OnEachFacet | There is one normal vector per each facet of the polymesh. |