Distribution |
An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
AtEachPoint | 0 | One normal vector is assigned to each vertex of the polymesh. |
OnEachFacet | 2 | There is one normal vector per each facet of the polymesh. |
OnePerFace | 1 | There is only one common normal vector assigned to the face/polymesh. |