Checks if rebarShape matches curves, hooks and end treatment. If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to false, then this method will ignore the hook information. If the RebarShapeDefinesEndTreatment flag in ReinforcementSettings has been set to false, then this method will ignore the end treatment information.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebarShape
- Type: Autodesk.Revit.DB.Structure RebarShape
A RebarShape element that defines the shape of the rebar.
- barType
- Type: Autodesk.Revit.DB.Structure RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- norm
- Type: Autodesk.Revit.DB XYZ
The normal to the plane that the rebar curves lie on.
- curves
- Type: System.Collections.Generic IList Curve
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
- startHook
- Type: Autodesk.Revit.DB.Structure RebarHookType
A RebarHookType element that defines the hook for the start of the bar.
- endHook
- Type: Autodesk.Revit.DB.Structure RebarHookType
A RebarHookType element that defines the hook for the end of the bar.
- startHookOrient
- Type: Autodesk.Revit.DB.Structure RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
- endHookOrient
- Type: Autodesk.Revit.DB.Structure RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
- hookRotationAngleAtStart
- Type: System Double
The out of plane hook rotation angle at the start of the bar.
- hookRotationAngleAtEnd
- Type: System Double
The out of plane hook rotation angle at the end of the bar.
- endTreatmentTypeIdAtStart
- Type: Autodesk.Revit.DB ElementId
The end treatment type id at the start of the bar.
- endTreatmentTypeIdAtEnd
- Type: Autodesk.Revit.DB ElementId
The end treatment type id at the end of the bar.
Return Value
True if rebarShape matches curves and hooks.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input curves is empty. -or- The input curves contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation. -or- the parameter endTreatmentTypeIdAtStart is not an EndTreatmentType element. -or- the parameter endTreatmentTypeIdAtEnd is not an EndTreatmentType element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | norm has zero length. -or- A value passed for an enumeration argument is not a member of that enumeration |