RebarShapeMatchesCurvesHooksAndEndTreatment Method


Rebar Rebar Shape Matches Curves Hooks And End Treatment Method

Note: This API is now obsolete.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.RebarShapeMatchesCurvesAndTerminationsData(RebarShape rebarShape, RebarBarType barType, XYZ norm, IList<Curve> curves, BarTerminationsData barTerminationsData) instead.")]
public static bool RebarShapeMatchesCurvesHooksAndEndTreatment(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ norm,
	IList<Curve> curves,
	RebarHookType startHook,
	RebarHookType endHook,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	double terminationRotationAngleAtStart,
	double terminationRotationAngleAtEnd,
	ElementId endTreatmentTypeIdAtStart,
	ElementId endTreatmentTypeIdAtEnd
)

Parameters

rebarShape RebarShape
barType RebarBarType
norm XYZ
curves IList Curve
startHook RebarHookType
endHook RebarHookType
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
terminationRotationAngleAtStart Double
terminationRotationAngleAtEnd Double
endTreatmentTypeIdAtStart ElementId
endTreatmentTypeIdAtEnd ElementId

Return Value

Boolean
See Also