Calculates the intersection of the specified face with this face and returns the intersection results.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Face
The specified face to intersect with this face.
Return Value
- FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
- SetComparisonResult.NonIntersecting - There is no intersection found.
Remarks
This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
- A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
- A cylindrical face that fully intersects another face in a single curve, when the other face is planar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | The face is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | The intersection calculation fails. |