Intersect Method (Face)


Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceIntersectionFaceResult Intersect(
	Face face
)
Visual Basic
Public Function Intersect ( _
	face As Face _
) As FaceIntersectionFaceResult
Visual C++
public:
FaceIntersectionFaceResult Intersect(
	Face^ face
)

Parameters

face
Type: Autodesk.Revit.DBFace
The specified face to intersect with this face.

Return Value

  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.

Remarks

This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException The face is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException The intersection calculation fails.

See Also