An Enum indicating the type of error associated with a KeyBasedTreeEntry.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
DuplicateEntry | The same entry appears more than once in the KeyBasedTreeEntries object. |
MissingParent | The parent specified for a entry does not exist in the KeyBasedTreeEntires object. |
CircularParentage | A sub-node has been specified as a parent of one of its ancestors. |
InvalidClassificationCode | The classification code does not match the level and parent code. |
BadClassificationLevel | The classification level is not an integer in range between 1 and 5 inclusive. |
BadClassificationCategoryId | The classification category id is not Revit BuiltInCategory id. |