KeyBasedTreeEntryErrorType Enumeration


Key Based Tree Entry Error Type Enumeration

An Enum indicating the type of error associated with a KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum KeyBasedTreeEntryErrorType
Members
Member name Value Description
BadClassificationCategoryId 5 The classification category id is not Revit BuiltInCategory id.
BadClassificationLevel 4 The classification level is not an integer in range between 1 and 5 inclusive.
CircularParentage 2 A sub-node has been specified as a parent of one of its ancestors.
DuplicateEntry 0 The same entry appears more than once in the KeyBasedTreeEntries object.
InvalidClassificationCode 3 The classification code does not match the level and parent code.
MissingParent 1 The parent specified for a entry does not exist in the KeyBasedTreeEntires object.
See Also