Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- column
- Type: Autodesk.Revit.DB FamilyInstance
The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
- target
- Type: Autodesk.Revit.DB Element
A proposed target element for a column attachment.
Remarks
Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |