Column |
Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- column FamilyInstance
- The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
- target Element
- A proposed target element for a column attachment.
Return Value
Boolean
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.