RenderNode Class


This is the base class of all render nodes in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public class RenderNode : IDisposable
Visual Basic
Public Class RenderNode _
	Implements IDisposable
Visual C++
public ref class RenderNode : IDisposable

Remarks

A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.

Inheritance Hierarchy

See Also