RenderNode Class


Render Node Class

This is the base class of all render nodes in a model-exporting process.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RenderNode : IDisposable

The RenderNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NodeName A readable name of the output node.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RenderNode
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.
See Also
Inheritance Hierarchy