Creates a new detail curve element.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the detail curve is to be visible.
- geometryCurve
- Type: Autodesk.Revit.DB Curve
The internal geometry curve for detail curve. It should be a bound curve.
Return Value
If successful a new detail curve element. Otherwise a null reference ( Nothing in Visual Basic) .Remarks
Different type of detail curve element will be returned according to the type of geometry curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when curve is not in plane of the view |