NewDetailCurve Method


Item Factory Base New Detail Curve Method

Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DetailCurve NewDetailCurve(
	View view,
	Curve geometryCurve
)

Parameters

view View
The view in which the detail curve is to be visible.
geometryCurve Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

DetailCurve
If successful a new detail curve element. Otherwise .
Exceptions
Exception Condition
ArgumentException Thrown when curve is not in plane of the view
Remarks
Different type of detail curve element will be returned according to the type of geometry curve.
See Also