GetFormatOptions Method (ForgeTypeId)


Gets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions(
	ForgeTypeId specTypeId
)
Visual Basic
Public Function GetFormatOptions ( _
	specTypeId As ForgeTypeId _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions(
	ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the spec.

Return Value

A copy of the FormatOptions.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also