GetFormatOptions Method (ForgeTypeId)


Units Get Format Options Method

Gets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FormatOptions GetFormatOptions(
	ForgeTypeId specTypeId
)

Parameters

specTypeId ForgeTypeId
Identifier of the spec.

Return Value

FormatOptions
A copy of the FormatOptions.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also