The filter string representing a collection of extensions allowed by the dialog.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The required format for this string is a collection of one or more filter labels (representing the text the user will see in the Files of Type pulldown) plus an associated file matching string separated by the '|' character. Some examples of valid filter strings:- "Revit Files (*.rvt)|*.rvt
- "Revit Projects (*.rvt)|*.rvt|Revit Families (*.rfa)|*.rfa"
- "All files|*.*"
- "All Revit files (*.rvt, *.rfa, *.rte, *.rft)|*.rvt;*.rfa;*.rte;*.rft"
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: The input filter string does not meet the minimal requirements for a valid filter string. |
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was null |