Filter Property


File Dialog Filter Property

The filter string representing a collection of extensions allowed by the dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string Filter { get; set; }

Property Value

String
The required format for this string is a collection of one or more filter labels (representing the text the user will see in the Files of Type pulldown) plus an associated file matching string separated by the '|' character. Some examples of valid filter strings:
  • "Revit Files (*.rvt)|*.rvt
  • "Revit Projects (*.rvt)|*.rvt|Revit Families (*.rfa)|*.rfa"
  • "All files|*.*"
  • "All Revit files (*.rvt, *.rfa, *.rte, *.rft)|*.rvt;*.rfa;*.rte;*.rft"
Exceptions
Exception Condition
ArgumentException When setting this property: The input filter string does not meet the minimal requirements for a valid filter string.
ArgumentNullException When setting this property: A non-optional argument was null
See Also