Set the string value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
The family parameter of current type.
- value
- Type: System String
The new value string for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid. |