Family |
Set the string value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyParameter FamilyParameter
- The family parameter of current type.
- value String
- The new value string for family parameter.

Exception | Condition |
---|---|
ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is . |
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string. |
ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range. |
InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid. |