Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- datumEnd
- Type: Autodesk.Revit.DB DatumEnds
The end of the datum plane.
- view
- Type: Autodesk.Revit.DB View
The view on which the DatumPlane shows.
- pLeader
- Type: Autodesk.Revit.DB Leader
The Leader for setting the datum plane.
Remarks
The leader can be applied only to ends where the bubble is set to be shown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One of the conditions is not valid: the input leader and view is not null; The leader End, Elbow, Anchor should be in the view; the End of leader should be in the datum plane curves; Elbow is between End and Anchor. -or- The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |